Home | Profile | Register | Active Topics | Members | Search | FAQ
Save Password
Forgot your Password?

 All Forums
 General Discussion
 Collectors and Users Open Forum
 Stuck shutter on Lomo 135m
 New Topic
 Reply to Topic
 Printer Friendly
Author Previous Topic Topic Next Topic  
Filip Bakic

2 Posts
Posted - Apr 25 2022 :  4:02:03 PM  Show Profile  Reply with Quote
Today, my grandma gave me her Lomo 135m camera. It was almost not used at all, as she found the controlls to be too complicated. When examining it earlier today shutter seemed to work fine, but now it is not oppening. I have tried unjamming it with a tiny screwdriver and that gives me one shutter release when winding the knob. Also one thing that worked earlier is the flash unit, which still works now, just not when shooting the camera. When pressing the trigger the mechanism does work and film does advance, its just the shutter not opening regardless of the shutter speed i select. Any possible causes and/or solutions?
sean perry
United Kingdom
317 Posts
Posted - May 11 2022 :  10:43:12 AM  Show Profile  Reply with Quote
Hello Filip and welcome to the forum. I can't help, but I'm sure there are members who can help, though you may have to wait a while for someone who can help to reply.
Go to Top of Page
  Previous Topic Topic Next Topic  
 New Topic
 Reply to Topic
 Printer Friendly
Jump To:
USSRPhoto.com Forums © USSRPhoto.com Go To Top Of Page
Snitz Forums 2000